DMVPN Phase1

■Task

(1)以下の要件に従い, DMVPNを構築しなさい.

・Spoke間通信は必ずHubを経由すること.

・SpokeはHubとのみtunnelを構築すること.

・HubはNHRP multicast mappingを動的に生成すること.

・Tunnel I/Fでは以下のパラメータを使用すること.

– I/F number : 0

– ip address : 10.0.0.x/24 (xの値 : spoke1=1, spoke2=2, Hub=10)

– Tunnel Source I/F : Ethernet 0/0

– NHRP network id : 100

– NHRP authentication : cisco

(2)以下の要件に従い, EIGRPを設定しなさい.

・Hub, SpokeはTunnel I/F, Loopback I/FでEIGRPを有効化すること.

・HubはSpokeにdefault routeのみを広報すること.

・EIGRPでは以下のパラメータを使用すること.

– AS Number : 100

– Router id : Loopback I/FのIP addressを明示的に指定

(3)以下の出力を得なさい.

■Topology

■Pre-Config

Hub

ISP

Spoke1

Spoke2

■Answer

Hub:
conf t
!
interface tunnel 0
ip address 10.0.0.10 255.255.255.0
tunnel source ethernet 0/0
tunnel mode gre multipoint
ip nhrp network-id 100
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip summary-address eigrp 100 0.0.0.0 0.0.0.0
!
router eigrp 100
eigrp router-id 10.10.10.10
network 10.0.0.10 0.0.0.0
network 10.10.10.10 0.0.0.0
!
end

Spoke1:
conf t
!
interface tunnel 0
ip address 10.0.0.1 255.255.255.0
tunnel source ethernet 0/0
tunnel destination 192.168.10.1
ip nhrp network-id 100
ip nhrp authentication cisco
ip nhrp map multicast 192.168.10.1
ip nhrp map 10.0.0.10 192.168.10.1
ip nhrp nhs 10.0.0.10
!
router eigrp 100
eigrp router-id 1.1.1.1
network 1.1.1.1 0.0.0.0
network 10.0.0.1 0.0.0.0
!
end

Spoke2:
conf t
!
interface tunnel 0
ip address 10.0.0.2 255.255.255.0
tunnel source ethernet 0/0
tunnel destination 192.168.10.1
ip nhrp network-id 100
ip nhrp authentication cisco
ip nhrp map multicast 192.168.10.1
ip nhrp map 10.0.0.10 192.168.10.1
ip nhrp nhs 10.0.0.10
!
router eigrp 100
eigrp router-id 2.2.2.2
network 2.2.2.2 0.0.0.0
network 10.0.0.2 0.0.0.0
!
end

■Verify

■Note

このTaskでは, DMVPN Phase1の設定が求められている.

DMVPNには3つのPhaseがあり, Phase1ではGRE tunnelがHub/Spoke間のみで構成される. そのため, Spoke側はtunnel destination addressを指定し, Point-to-Pointする.

これにより, NHRPによってSpoke/Spoke間のtunnelが構築されること を防ぐ.

また, “HubはNHRP multicast mappingを動的に登録しなさい.”とあるため, “ip nhrp map multicast dynamic”を設定する.

一般的には使用されないが, Hubで以下のように設定することで, 静的にNHRP multicast mappingの登録ができる. これにより, Hubで”ip nhrp map multicast dynamic”を設定しなくともbroadcast/multicastを対象のSpokeにtunnel I/Fから送出可能となる.

Hub:
conf t
!
interface tunnel 0
ip nhrp map 10.0.0.1 192.168.1.1
ip nhrp map 10.0.0.2 192.168.2.1
ip nhrp map multicast 192.168.1.1
ip nhrp map multicast 192.168.2.1
!
end

■Reference

Configuration Guide : Dynamic Multipoint VPN

Cisco Learning Network : DMVPN 各フェーズの紹介

INE Blog : DMVPN Explained

シェアする

フォローする

関連コンテンツ