DMVPN Phase2

■Task

(1)以下の要件に従い, DMVPNを構築しなさい.

・Spoke1とSpoke2でdynamicにVPNを生成すること.

・Tunnel I/Fでは以下のパラメータを使用すること.

– I/F number : 0

– ip address : 10.0.0.x/24 (xの値 : spoke1=1, spoke2=2, Hub=10)

– Tunnel Source I/F : Ethernet 0/0

– NHRP network id : 100

– NHRP authentication : cisco

(2)以下の要件に従い, EIGRPを設定しなさい.

・Hub, SpokeはTunnel I/F, Loopback I/FでEIGRPを有効化すること.

・EIGRPでは以下のパラメータを使用すること.

– AS Number : 100

– Router id : Loopback I/FのIP addressを明示的に指定

(3)以下の出力を得なさい.

■Topology

■Pre-Config

Hub

ISP

Spoke1

Spoke2

■Answer

Hub:
conf t
!
interface tunnel 0
ip address 10.0.0.10 255.255.255.0
tunnel source ethernet 0/0
tunnel mode gre multipoint
ip nhrp network-id 100
ip nhrp authentication cisco
ip nhrp map multicast dynamic
no ip next-hop-self eigrp 100
no ip split-horizon eigrp 100
!
router eigrp 100
eigrp router-id 10.10.10.10
network 10.0.0.10 0.0.0.0
network 10.10.10.10 0.0.0.0
!
end

Spoke1:
conf t
!
interface tunnel 0
ip address 10.0.0.1 255.255.255.0
tunnel source ethernet 0/0
tunnel mode gre multipoint
ip nhrp network-id 100
ip nhrp authentication cisco
ip nhrp map multicast 192.168.10.1
ip nhrp map 10.0.0.10 192.168.10.1
ip nhrp nhs 10.0.0.10
!
router eigrp 100
eigrp router-id 1.1.1.1
network 1.1.1.1 0.0.0.0
network 10.0.0.1 0.0.0.0
!
end

Spoke2:
conf t
!
interface tunnel 0
ip address 10.0.0.2 255.255.255.0
tunnel source ethernet 0/0
tunnel mode gre multipoint
ip nhrp network-id 100
ip nhrp authentication cisco
ip nhrp map multicast 192.168.10.1
ip nhrp map 10.0.0.10 192.168.10.1
ip nhrp nhs 10.0.0.10
!
router eigrp 100
eigrp router-id 2.2.2.2
network 2.2.2.2 0.0.0.0
network 10.0.0.2 0.0.0.0
!
end

■Verify

■Note

このTaskでは, DMVPN Phase2の設定が求められている.

DMVPNには3つのPhaseがあり, Phase2ではGRE tunnelがHub/Spoke間に加えSpoke/Spoke間で動的に生成される.

そのため, 各Spokeもtunnel modeをgre multipointとする必要がある. また, Phase2でのEIGRPは以下2点を無効化する必要がある.

・split-horizon

HubはTunnel I/Fから学習した経路情報をTunnel I/Fから広報しなければいけないため, これを無効化する.

・next-hop-self

EIGRPでは, defaultで経路情報を広報する際にnext-hopを自身のアドレスに変換してから広報する. Phase2ではSpokeはSpokeに直接通信を行うため, これを無効化する.

また, Spoke/Spoke tunnelを動的に生成する際にはNHRP Resolution Request/Replyが使用される.動作の説明は以下の通り.

Ex. Spoke1(1.1.1.1/32)がSpoke2(2.2.2.2/32)に初めて通信を行う

(1)

Spoke1はSpoke2のNBMA address(192.168.2.1)を解決するため, HubにNHRP Resolution Requestを送信する.

(2)

Hubは”(1)”で受信したNBMA Resolution RequestをSpoke2に転送する.

(3)

Spoke2はNBMA Resolution Requestを受信したことで, Spoke1のNBMA address(192.168.1.1)を学習する.

(4)

Spoke2はNBMA Resolution ReplyをSpoke1に直接送信する.

(5)

Spoke1はNBMA Resolution Replyを受信することによりSpoke2のNBMA address(192.168.2.1)を解決することができる.

また, 初めてSpoke1がSpoke2と通信する際はHubに向けてパケットを送信する. これはNHRPによりSpoke2のNBMA addressが解決できていないためである.

そのため, はじめの通信はSpoke1 -> Hub -> Spoke2とHubを介した通信となる.

NHRPによりNBMA addressを解決できた後はGREのdestination ip addressを192.168.2.1としてパケットを送信する. これにより, Hubを介さずにSpoke2と直接通信が可能となる.

■Reference

Configuration Guide : Dynamic Multipoint VPN

Cisco Learning Network : DMVPN 各フェーズの紹介

INE Blog : DMVPN Explained

シェアする

フォローする

関連コンテンツ