Trouble Shooting Lab1_Answer

Trouble Ticket (Answer)                                             

Ticket1 (1点)

//回答

RT1(config)#arp 192.168.1.254 aabb.cc00.0300 arpa

//解説

これはRT1にStatic ARPが設定され, 192.168.1.254に対してERT1のEth0/0のMAC addressとは異なる値が紐付けられていることが原因となっている.

TCP/IPに従い通信を行う際は, IP addressに対する宛先MAC addressをARP tableから解決し, その値を使用してL2 frameを生成する.

そのため, Static ARPにより異なる値が紐付けられていると, ERT1は自身のMAC addressではないL2 frameを受信するためこれを破棄してしまう.

ここではERT1にて”show interfaces Ethernet 0/0″を使用し, Static ARPを適切な値に変更する.

Ticket2 (1点)

//回答

ERT3(config)#router eigrp 300
ERT3(config-router)#no passive-interface ethernet 0/0
!
RT3(config)#interface ethernet 0/0
RT3(config-if)#no shutdown

//解説

ERT3ではEIGRPにて”passive-interface default”が設定されている.

Passive I/Fに設定されているとHello packetとRouting Updateが抑止されるためNeighborになることができない.

ここでは, “no passive-interface ethernet 0/0″を設定することでこれを解決できる.

また, RT3のEthernet 0/0がshutdownとなっているため, “no shutdown”によりポートを開放する必要がある.

EIGRPでトラブルが発生していたとしても, 原因はEIGRPだけにあるとは限らないため注意が必要.

Ticket 3 (2点)

//回答

ERT2(config)#interface ethernet 1/0
ERT2(config-if)#no ip ospf message-digest-key 1
ERT2(config-if)#ip ospf message-digest-key 1 md5 NETWORK

//解説

ERT1とERT2でpasswordが一致していないため, これを修正する必要がある.

Configを見るだけでは一致しているように見えるが, ERT2はNETWORKの末尾に半角スペースが含まれており, これも文字列としてカウントされてしまう.

次のようにNeighborになるための条件を適切なshow commandで確認していくと, Authenticationのみ一致していると断言することができない.

1.Hello/Dead interval : 一致している

2.Area : 一致している

3.Network Mask : 一致している

4.Stub flag : 一致している

5.MTU : 一致している

6.Authentication : ???

このように潰していけば, Authenticationを疑うことができ, “debug ip ospf adj”にて確証を得ることができる.

そして, ERT1とERT2にてauthenticationの設定をこのようにダブルクリックすると, ERT2に半角スペースが含まれていることが確認できるので, これを修正する.

Ticket 4 (4点)

Ticket 4-1

//回答

ERT3(config)#router ospf 300
ERT3(config-router)#network 3.3.3.3 0.0.0.0 area 0
!
ERT1(config)#router bgp 100
ERT1(config-router)#neighbor 3.3.3.3 ebgp-multihop 255

//解説

ERT1,2,3はお互いのLoopback I/Fのaddressを使用してEBGP neighborを形成することを期待されている.

しかし, ERT3のLoopback I/FのaddressがOSPFで広報されていないため疎通性がない. ERT3にてこれを広報することにより, 疎通性が確保できる.

また, ERT1ではERT3(3.3.3.3)に対してEBGP neighborのmulti hopが設定されていない. defaultではEBGPのTTLは1であるため, このままではERT3(3.3.3.3)に到達できず, EBGP neighborになることができない.

ERT1にてmulti hopを設定することにより, これを解決することができる.

Ticket4-2

//回答

ERT3(config)#router bgp 300
ERT3(config-router)#bgp aggregate-timer 0

//解説

BGPではdefaultで30秒ごとにbgp tableに登録された経路情報を集約する.

そのため, タイミングによっては以下のように新しくBGP tableに追加されたchild route(192.168.8.0/24)がsuppressedとならず, 広報されてしまう可能性がある.

この30秒ごとに集約 いう動作はaggregate-timerと呼ばれ,  これを0にすることで即時集約となり, Child routeは必ずsuppressedとなり広報されることがなくなる.

//Reference

Command Reference : bgp aggregate-timer

Ticket5 (4点)

//回答

ERT2(config)#interface ethernet 0/0
ERT2(config-if)#ip helper-address 172.16.23.3
!
ERT3(config)#ip dhcp pool RT2
ERT3(dhcp-config)#host 192.168.2.20 255.255.255.0
ERT3(dhcp-config)#client-identifier 01aa.bbcc.0001.00
ERT3(dhcp-config)#default-router 192.168.2.254

//解説

RT2はDHCP ServerであるERT3と異なるネットワークに属しているため, このままではDHCPでアドレスを取得することができない.

そのため, ERT2をDHCP relay agentとして動作させる.

次に, RT2には192.168.2.20/24を固定で割り当てたい とあるため, manual bindingという機能を使用する.

manual bindingとは, DHCPのOption 61で定義されているclient identifierに基づき固定でアドレスを払い出す技術である.

今回はRT2で”ip address dhcp client-id ethernet 0/0″と設定されているため, client identifierはRT2 Ethernet 0/0のMac addressの先頭に”01″を付与したものとなる.

また, 出力からERT2(192.168.2.254)がdefault gatewayという情報もDHCPで配布されていることが確認できるため, この設定を忘れないように注意.

//Reference

Command Reference : ip address dhcp

Configuration Guide : Configuring Manual Bindings

シェアする

フォローする

関連コンテンツ

コメント

  1. […] 参考として、前回のネットワークコンテストの内容を紹介します。問題→https://it-networking.jp/page/2回答→https://it-networking.jp/2018/10/14/975.html […]