その他

Multicast Routing on Anycast RP

[:ja]

■Task

以下の出力を得なさい.

また, RT1にloopback11(11.11.11.11/32)とRT2にloopback22(22.22.22.22/32)を設定してもよい.

 

■Topology

 

■Pre-Config

RT1

RT2

Sender

Receiver

■Answer

RT1:
conf t
!
interface loopback 11
ip address 11.11.11.11 255.255.255.255
!
ip msdp peer 22.22.22.22 connect-source loopback 11
ip msdp originator-id loopback 11
!
router ospf 100
network 11.11.11.11 0.0.0.0 area 0
!
end

RT2:
conf t
!
interface loopback 22
ip address 22.22.22.22 255.255.255.255
!
ip msdp peer 11.11.11.11 connect-source loopback 22
ip msdp originator-id loopback 22
!
router ospf 100
network 22.22.22.22 0.0.0.0 area 0
!
end

■Verify

■Note

このTaskは, RT1とRT2でMSDP peerを確立することで要求された出力を得ることができる.

Anycast RP(Rendezvous Point)環境では, MSDP peerを確立しなればmulticast routingを実現できない. Senderから送信されたmulticastがRPであるRT1に到達するも, RT1に239.1.1.1のmulticast routeが存在しないため通信が成立しない.

RT1とRT2でMSDP peerを確立していると, RT1は受信したmulticast packetをRT2にMSDP Source IFのIP addressでカプセル化して送信する.

 

RT2はカプセル化を解除することで, multicast routeに従いReceiverに送信できる. また, この際にRT2はRT1に対してPIM join messageを送信する.

 

これにより, RT1に(S,G) Entryが生成され, これ以降の通信はカプセル化されずに送信される.

また, MSDPではdefaultでoriginator-idがRPのアドレスとなるため”ip msdp originator-id x”で変更する必要がある.

■Reference

Configuration Guide : Using MSDP to interconnect Multiple PIM-SM Domains

Command Reference : ip msdp peer

Command Reference : ip msdp originator-id

 

 [:en]

■Task

Get the same output with below.

You can config loopback11(11.11.11.11/32) on RT1 and loopback22(22.22.22.22/32) on RT2.

 

■Topology

 

■Pre-Config

RT1

RT2

Sender

Receiver

■Answer

RT1:
conf t
!
interface loopback 11
ip address 11.11.11.11 255.255.255.255
!
ip msdp peer 22.22.22.22 connect-source loopback 11
ip msdp originator-id loopback 11
!
router ospf 100
network 11.11.11.11 0.0.0.0 area 0
!
end

RT2:
conf t
!
interface loopback 22
ip address 22.22.22.22 255.255.255.255
!
ip msdp peer 11.11.11.11 connect-source loopback 22
ip msdp originator-id loopback 22
!
router ospf 100
network 22.22.22.22 0.0.0.0 area 0
!
end

■Verify

■Note

If you establish MSDP peer between RT1 and RT2, you can get the requested output.

You can’t forward multicast packet in Anycast RP environment if you don’t use MSDP.

When multicast packet that is sent from Sender arrive at RT1, RT1 don’t have multicast route for packet.

Therefore, RT1 can’t forward multicast packet.

If RT1 establish MSDP peer with RT2, RT1 encapsulates multicast packet with IP address of MSDP Source IF to forward to RT2.

 

When RT2 receives multicast packet that is encapsulated MSDP, RT decapsulate it and forward packet to receiver.

Also, RT2 sent PIM join message to RT1 when RT2 receive MSDP packet.

 

As a result, RT1 creates (S,G) Entry and RT1 can forward multicast packet without encapsulation.

Also, MSDP uses RP address to originator-id in default.

Therefore, You must change originator-id using “ip msdp originator-id x” command.

■Reference

Configuration Guide : Using MSDP to interconnect Multiple PIM-SM Domains

Command Reference : ip msdp peer

Command Reference : ip msdp originator-id

 

 [:]